Verify degraded

Incident Report for Idura

Resolved

This incident has been resolved.
Posted Mar 31, 2026 - 14:46 CEST

Monitoring

Between 11:30 and 11:39 (Copenhagen time), a system component exhibited intermittent erroneous behavior.

25 logins failed to complete succesfully during the time window.

We continue to monitor the behavior closely.
Posted Mar 31, 2026 - 11:58 CEST

Investigating

The Verify service powering authentications is currently experiencing issues with an underlying infrastructure components.
Service is degraded.
Posted Mar 31, 2026 - 11:34 CEST
This incident affected: Criipto Verify Authentication Core.