Connection issues to criipto.id domains

Incident Report for Idura

Resolved

This incident has been resolved.
Posted Apr 07, 2026 - 16:01 CEST

Monitoring

We have reports from customers and our own testing that the network issue is resolved. We will continue to monitor.
Posted Apr 07, 2026 - 15:43 CEST

Update

Users report, and Idura staff confirms, that mobile connections appear unaffected.
Multiple network locations still fail, likely due to a faulty network location in Azure.
Posted Apr 07, 2026 - 15:06 CEST

Update

We are continuing to investigate. Multiple network locations are unable to connect to Idura/Criipto domains, while some succeed, and we are still observing succesful logins.
Posted Apr 07, 2026 - 14:35 CEST

Investigating

We have reports of users failing to connect to *.criipto.id based domains. We are investigating.
Posted Apr 07, 2026 - 14:14 CEST
This incident affected: Criipto Verify Authentication Core and Criipto Signatures.